
了解如何导⼊基于XML和静态⽹格的⾃定义多旋翼模型的流程。

软件要求：Windows 10及以上版本；RflySim⼯具链 ；3ds Max2021；Unreal

Engine4.27。

硬件要求：笔记本/台式电脑1台 。

例程⽬录：

：⾃定义多旋翼三维模型加载实验原理

：其内为待处理的模型数据

：其内为处理完成可直接导⼊的模型数据

说明：本步骤以3ds Max为例进⾏演⽰，若已经熟悉相关流程，您也可以使⽤其他⽀持的三

维建模软件（如Maya、Blender、Cinema 4D等）或CAD软件（如SOLIDWORKS、

基于RflySim3D接⼝的⾃定义多旋翼模

型加载实验

1. 实验⽬的

2. 实验要求

[1]

[2]

3.实验地址

[安装⽬录]\RflySimAPIs\3.RflySim3DUE\1.BasicExps\e1_CusLoadDroneyeeX680

Intro.pdf

VehicleModel

DroneyeeX680

4. 实验内容或步骤

4.1 在三维建模软件中处理模型（选做）
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Inventor等）进⾏模型处理。不同软件的具体操作⽅法会有所差异，但核⼼流程和要求相

同。

完成3dsMax安装后，通过如下⽅式打开3dsMax中⽂版

打开3dsMax后，通过下图⽅式选择打开源⽂件所在⽬录（这⾥是打开max⽂件，若使⽤其

它三维格式，应通过⽂件-导⼊的⽅式）

然后在弹出窗⼝中找到本实验⽬录下的" "⽬录并找到"

"，选择打开

步骤1: 通过3dsMax打开模型（其他软件类似）

VehicleModel DroneyeeX680.max
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VehicleModel
VehicleModel/DroneyeeX680.max


在3Dsmax中选中所有组件，点击菜单栏"组"-"组"，就可以将所有组件弄成⼀个整体，这时

候可以调整⻜机的位置，姿态，轴的位置，轴的⽅向等。需要满⾜以下要求：

1）确保机头⽅向指向3Ds Max的x轴正⽅向，机顶指向z轴正⽅向（向上）；

2）确保⻜机的质⼼在3Ds Max的中⼼；

3）确保模型中没有隐形（不显⽰的）组件，如果有需要删除。

如下图，点击⼯具栏"移动"按钮，再点击选中机⾝或螺旋桨对象，就可以在下⽅状态栏中读

取对象的三维坐标（将坐标都输⼊为0就可以将对象挪到中⼼）。

步骤2: 模型坐标归零
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点击机⾝就可以看到机⾝的三维坐标（x,y,z）=[-0.449,- 0.363,0]

右上螺旋桨[24.977, -24.439, 11.222]，左下螺旋桨[-25.99, 22.528, 11.022],

左上螺旋桨[24.977, 24.693, 11.022]，右下螺旋桨[-25.99, -22.274, 11.022]。

步骤3: 记录机⾝和螺旋桨相对位置
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将各个螺旋桨的坐标减去机体的坐标，就可以得到各个螺旋桨相对机体中⼼的三维坐标。由

于3DsMax是采⽤前左上的右⼿坐标系，UE采⽤前右上的左⼿坐标系，因此需要对y轴进⾏

反向。

这样就得到了右上、左下、右下、左上的坐标序列为：[25.4260,24.0760,11.2220],

[-25.5410,-22.8910,11.0220], [25.4260,-25.0560,11.0220],[-25.5410,21.9110,11.0220],这

⼏个坐标值留着备⽤。然后，记录⻜机质⼼到地⾯（机体最低端）的距离，这⾥⼤约取

8cm。

将DroneyeeX680.max复制两份，分别命名为DroneyeeX680Body.max和

DroneyeeX680Prop.max。在DroneyeeX680Body.max⽂件中移除四个螺旋桨，并将机⾝

移动到3DsMax的坐标中⼼；在DroneyeeX680Prop.max中移除机体组件和三个螺旋桨，只

留下⼀个，然后移动到3Dsmax坐标中⼼。

导出得到FBX模型⽂件，分别点击3DsMax的菜单-⽂件-导出-导出，按下图所⽰配置，导出

得到DroneyeeX680Body.FBX和DroneyeeX680Prop.FBX⽂件

其他软件导出FBX的⽅法：

Maya：File > Export All > FBX Export，注意坐标轴设置为Z-Up

Blender：File > Export > FBX，Forward设置为-Y Forward，Up设置为Z Up

Cinema 4D：File > Export > FBX，确保坐标系正确转换

SOLIDWORKS：通过Datasmith插件导出或使⽤第三⽅FBX导出插件

关键导出配置如下图所⽰。注：摄像机、动画、灯光都不要勾选

步骤4: 分别导出机⾝和螺旋桨fbx（适⽤于各种三维软件）
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任意打开⼀个UE⼯程，在其Content⽬录新建⼀个⽂件夹（这⾥命名为DroneyeeX680），

如下图进⼊该⽂件夹后，点击导⼊按钮，依次将DroneyeeX680Body.FBX和

DroneyeeX680Prop.FBX导⼊进来

4.2 将该fbx模型导⼊UE处理并烘培（选做，以

UE4为例）

步骤1: fbx模型导⼊UE

6 / 20



由于我们的fbx模型没有定义材质，因此导⼊进来是⽩⾊的，并不美观。需要双击

DroneyeeX680Body⽹格体资产，选择资产详细查看材质⾯板，在其中对关键部件添加颜

⾊材质，例如碳纤维的⿊⾊（这⾥需要引⽤到当前⽬录下定义的材质，材质及其引⽤资产的

路径只能相对于当前的内容⽬录，不能引⽤到UE引擎⾃带的材质，否则最终导⼊

RflySim3D⽆法正确显⽰）。同时，复制⼀个DroneyeeX680Prop组件命名为

DroneyeeX680Prop_2，将其材质设置为不同的颜⾊，以区分⻜机的靠前的两个螺旋桨和靠

后的两个螺旋桨。如果导⼊其他的其他模型本⾝拥有材质贴图，则需要保证贴图纹理贴在正

确的位置上。

步骤2: 处理模型材质
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在上图中点击"保存所有内容"，在编辑->项⽬设置->打包中确保如下设置：

然后在⽂件->烘培Windows的内容，进⾏烘培：

步骤3: 项⽬打包设置与烘焙
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烘焙完成后，可以

在 【该⼯程⽂件夹】\Saved\Cooked\WindowsNoEditor\【⼯程名】\Content\ 下，将整

个"DroneyeeX680"⽬录复制出来备⽤。

导出模型后，我们还需要编写XML⽂件来帮助RflySim3D识别螺旋桨位置、转动⽅向、材质

等。

4.3 烘焙完成的模型导⼊RflySim3D

步骤1: 编写XML⽂件
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<?xml version="1.0"?>
<vehicle>
    <ClassID>3</ClassID>               <!--类型，3表⽰四旋翼⽆⼈机-->
    <DisplayOrder>1015</DisplayOrder>  <!--显⽰顺序，越⼩在切换列表（c键）越靠前-->
    <Name>DroneyeeX680</Name>          <!--显⽰名称-->
    <Scale>      <!--缩放-->
        <x>1</x>
        <y>1</y>
        <z>1</z>
    </Scale>
    <AngEulerDeg> <!--创建时的初始姿态⾓-->
        <roll>0</roll>
        <pitch>0</pitch>
        <yaw>0</yaw>
    </AngEulerDeg>
    <body>
        <ModelType>0</ModelType> <!--0表⽰静态⽹格，1表⽰动画，2-4表⽰蓝图-->
        <MeshPath>/Game/DroneyeeX680/DroneyeeX680Body</MeshPath> <!--mesh路径，⿏标悬
停在资产上会显⽰资产路径，资产完整路径=显⽰的资产路径+资产名称-->
        <MaterialPath></MaterialPath>
        <AnimationPath></AnimationPath>
        <CenterHeightAboveGroundCm>8</CenterHeightAboveGroundCm> <!--质⼼离地⾯的⾼
度，从图4下⾯知道为8-->
        <NumberHeigthAboveCenterCm>20</NumberHeigthAboveCenterCm> <!--标签离地⾯的⾼
度-->
    </body>
    <ActuatorList> <!--是mesh类型，有执⾏器列表-->
        <Actuator>
            <MeshPath>/Game/DroneyeeX680/DroneyeeX680Prop</MeshPath> <!--执⾏器mesh
路径，参考body路径获取-->
            <MaterialPath></MaterialPath>
            <RelativePosToBodyCm> <!--执⾏器相对于Body的偏移，由图4知道
[25.4260,24.0760,11.2220],[-25.5410,-22.8910,11.0220], [25.4260,  
-25.0560,11.0220], [-25.5410,21.9110,11.0220]-->
                <x>25.4260</x>
                <y>24.0760</y>
                <z>11.2220</z>
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg> <!--执⾏器相对于body的姿态⾓-->
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
            <RotationAxisVectorToBody> <!--执⾏器相对于body的旋转轴，显⽰是z轴--
>
                <x>0</x>
                <y>0</y>
                <z>1</z>                    
            </RotationAxisVectorToBody>
            <RotationModeSpinOrDefect>0</RotationModeSpinOrDefect>
        </Actuator>

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
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        <Actuator>
            <MeshPath>/Game/DroneyeeX680/DroneyeeX680Prop_2</MeshPath>
            <MaterialPath></MaterialPath>
            <RelativePosToBodyCm>
                <x>-25.5410</x>
                <y>-22.8910</y>
                <z>11.0220</z>
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
            <RotationAxisVectorToBody>
                <x>0</x>
                <y>0</y>
                <z>1</z>                    
            </RotationAxisVectorToBody>
            <RotationModeSpinOrDefect>0</RotationModeSpinOrDefect>
        </Actuator>
        <Actuator>
            <MeshPath>/Game/DroneyeeX680/DroneyeeX680Prop</MeshPath>
            <MaterialPath></MaterialPath>
            <RelativePosToBodyCm>
                <x>25.5410</x>
                <y>-25.0560</y>
                <z>11.0220</z>
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
            <RotationAxisVectorToBody>
                <x>0</x>
                <y>0</y>
                <z>1</z>                    
            </RotationAxisVectorToBody>
            <RotationModeSpinOrDefect>0</RotationModeSpinOrDefect>
        </Actuator>
        <Actuator>
            <MeshPath>/Game/DroneyeeX680/DroneyeeX680Prop_2</MeshPath>
            <MaterialPath></MaterialPath>
            <RelativePosToBodyCm>
                <x>-25.528</x>
                <y>21.9110</y>
                <z>11.0220</z>
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>

53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
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81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
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                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
            <RotationAxisVectorToBody>
                <x>0</x>
                <y>0</y>
                <z>1</z>                    
            </RotationAxisVectorToBody>
            <RotationMode>0</RotationMode>
        </Actuator>
    </ActuatorList>
    <OnboardCameras> <!--⻜⾏器上的相机，从其他xml复制保持不变-->
        <camera>
            <name>Chase_Camera</name>
            <RelativePosToBodyCm>
                <x>-100</x>
                <y>0</y>
                <z>5</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>
        <camera>
            <name>Front_Camera</name>
            <RelativePosToBodyCm>
                <x>20</x>
                <y>0</y>
                <z>0</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>   
        <camera>
            <name>Back_Camera</name>                
            <RelativePosToBodyCm>
                <x>-20</x>
                <y>0</y>
                <z>0</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>180</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>                  
        <camera>

106
107
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109
110
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113
114
115
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117
118
119
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122
123
124
125
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127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
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            <name>Right_Camera</name>                 
            <RelativePosToBodyCm>
                <x>0</x>
                <y>20</y>
                <z>0</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>90</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>  
        <camera>
            <name>Left_Camera</name>                
            <RelativePosToBodyCm>
                <x>0</x>
                <y>-20</y>
                <z>0</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>0</pitch>
                <yaw>-90</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>      
        <camera>
            <name>Down_Camera</name>                
            <RelativePosToBodyCm>
                <x>0</x>
                <y>0</y>
                <z>-20</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>-90</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>  
        <camera>
            <name>Up_Camera</name>                 
            <RelativePosToBodyCm>
                <x>0</x>
                <y>0</y>
                <z>20</z>                        
            </RelativePosToBodyCm>
            <RelativeAngEulerToBodyDeg>
                <roll>0</roll>
                <pitch>90</pitch>
                <yaw>0</yaw>
            </RelativeAngEulerToBodyDeg>
        </camera>                                             

159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
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184
185
186
187
188
189
190
191
192
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194
195
196
197
198
199
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将编写好的XML⽂件拷⻉到之前⽣成的DroneyeeX680⽂件夹中，再⼀起拷⻉

到 RflySim3D\RflySim3D\Content ⽬录

打开RflySim3D，⿏标双击地⾯+O+3创建⼀架四旋翼，按下C键可以切换⻜机样式，看看⾃

⼰的⻜机模型是否已经导⼊。

注：XML中DisplayOrder数字⼩于1000就会超过内置模型排到最前边，变成默认显⽰⻜

机。详细教程如下：

RflySim:如何将你的⻜机三维模型导⼊到基于UE的RflySim3D程序中并⽤于视景仿真，本视

频观看地址：

优酷：

YouTube：

B站：

此⽂件⽬录下有⼀个已经完成的例程，找到DroneyeeX680⽂件夹，将⽂件夹复制到

PX4PSP\RflySim3D\RflySim3D\Content⽬录下。最后打开RflySim3D，⿏标双击地⾯

+O+3，就能创建出这个ClassID为3的⻜机，然后按C键切换到刚刚导⼊的DroneyeeX680⻜

机即可。

    </OnboardCameras>
</vehicle>

步骤2: 导⼊RflySim3D

https://v.youku.com/v_show/id_XNDcwNjA4NzIxMg==.html

https://youtu.be/mKUehJwqqsU

https://www.bilibili.com/video/BV13a411i7sH?p=9

步骤3: 最终效果
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有关XML配置⽂件的格式，请参考

中的8.1节

本实验不仅⽀持3ds Max，还⽀持多种主流的三维建模和CAD软件进⾏⾃定义载具开发：

Autodesk 3ds Max (2016-2022)：主要演⽰软件，⽀持直接导出FBX

Autodesk Maya：通过FBX格式⽀持，业界标准建模软件

Blender：开源免费建模软件，可导出FBX格式

Maxon Cinema 4D：专业建模渲染软件，通过Datasmith⽀持

McNeel Rhinoceros：⼯业设计软件，⽀持导出插件

Trimble SketchUp Pro：建筑设计软件，⽀持导出插件

SOLIDWORKS：⼯业设计标准软件，通过Datasmith导出插件

5. 关键知识点

关键知识点1：XML配置⽂件格式

[RflySim安装⽬录]/RflySimAPIs/3.RflySim3DUE/API.pdf

关键知识点2：⽀持的三维建模软件和⽂件格式

主要⽀持的三维建模软件

主要⽀持的CAD软件
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Autodesk Inventor：机械设计软件，直接⽀持CAD格式

CATIA V5：航空航天⼯业软件，直接⽀持CAD格式

PTC Creo (Pro/ENGINEER)：机械设计软件，直接⽀持CAD格式

Siemens NX：⾼端CAD软件，直接⽀持CAD格式

原⽣⽀持格式（⽆需插件）：

FBX：主要推荐格式，⽀持⽹格、动画、材质、纹理的完整导⼊

OBJ：基础⽹格格式，仅⽀持⼏何体，需要单独处理材质

通过Datasmith⽀持的格式（需要插件）：

STEP ( *.step ,  *.stp )：国际标准CAD交换格式，⽀持AP203、AP214、AP242

IGES ( *.iges ,  *.igs )：早期CAD交换格式，⽀持5.1、5.2、5.3版本

3DXML：Dassault Systèmes的3D交换格式

JT Open：Siemens PLM的轻量化格式

Parasolid ( *.x_t )：⼏何建模内核格式

3DS：早期3ds Max格式（已较少使⽤）

Alembic ( *.abc )：动画⼏何体缓存格式

glTF：现代Web 3D标准格式（实验性⽀持）

不同建模软件和三维格式使⽤不同的坐标系统，在导⼊UE时需要注意转换：

软件/格式

坐标系类

型

前进⽅向 向上⽅向 向右⽅向 备注

3ds Max

右⼿坐标

系

+X +Z +Y

本例程使

⽤

Maya

右⼿坐标

系

+Z +Y +X 需要转换

Blender

右⼿坐标

系

+Y +Z +X 需要转换

Unreal Engine⽀持的三维模型格式

关键知识点3：坐标系转换差异

坐标系对照表
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软件/格式

坐标系类

型

前进⽅向 向上⽅向 向右⽅向 备注

Cinema 4

D

左⼿坐标

系

+Z +Y +X 需要转换

Unreal En

gine

左⼿坐标

系

+X +Z +Y ⽬标格式

1. 从3ds Max到UE：需要对Y轴进⾏反向（本例程已处理）

2. 从Maya到UE：需要旋转90度并调整轴向

3. 从Blender到UE：导出时选择正确的轴向设置

4. 模型朝向：确保机头始终指向前进⽅向（UE中的+X⽅向）

5. 缩放单位：注意不同软件的单位制（厘⽶、⽶、英⼨）转换

UE官⽅FBX导⼊教程：

UE官⽅Datasmith教程：

Blender到UE⼯作流程：

Maya到UE⼯作流程：

Blender建模导⼊UE教程：B站搜索"Blender UE4 导⼊教程"

SOLIDWORKS到UE⼯作流程：YouTube搜索"SOLIDWORKS to Unreal Engine"

通⽤CAD软件导⼊教程：各软件官⽅⽹站的UE集成⽂档

3ds Max坐标轴设置：File > Export > FBX Export Options > Axis Conversion

转换注意事项

关键知识点4：其他三维模型导⼊⽅式参考教程

官⽅教程链接

https://docs.unrealengine.com/4.27/en-US/WorkingWithContent/Importing/FBX/

https://docs.unrealengine.com/5.0/en-US/datasmith-supported-software-and-fil

e-types/

https://docs.unrealengine.com/4.27/en-US/WorkingWithContent/Importing/

https://docs.unrealengine.com/4.27/en-US/WorkingWithContent/Importing/FBX/

FBXBestPractices/

第三⽅参考教程

坐标轴处理参考
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Maya坐标轴设置：FBX Export > Advanced Options > Axis Conversion

Blender坐标轴设置：Export > FBX > Transform > Forward/Up Axis设置

1. XML⽂件规则

2. RflySim3D快捷键接⼝总览

3. RflySim3D模型导⼊总览

3ds Max官⽅⽂档：

Maya官⽅⽂档：

Blender官⽅⽂档：

Cinema 4D官⽅⽂档：

SOLIDWORKS⽤⼾指南：

Autodesk Inventor帮助：

CATIA⽤⼾⽂档：

PTC Creo帮助中⼼：

UE官⽅中⽂⽂档：

FBX导⼊最佳实践：

6.参考资料

6.1 RflySim3D相关⽂档

../../API.pdf

../../API.pdf

../../API.pdf

6.2 三维建模软件官⽅⽂档

建模软件

https://help.autodesk.com/view/3DSMAX/2023/CHS/

https://help.autodesk.com/view/MAYAUL/2023/CHS/

https://docs.blender.org/manual/zh-hans/latest/

https://help.maxon.net/c4d/

CAD软件

https://help.solidworks.com/

https://help.autodesk.com/view/INVNTOR/2023/CHS/

https://help.3ds.com/catia/

https://support.ptc.com/help/creo/

6.3 Unreal Engine相关资源

https://docs.unrealengine.com/4.27/zh-CN/

https://docs.unrealengine.com/4.27/en-US/WorkingWithContent/Importing/FBX/

FBXBestPractices/
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Datasmith⽀持的软件列表：

UE坐标系统说明：

Autodesk FBX Converter：

Open3D：开源三维数据处理库，⽀持多种格式转换

MeshLab：开源⽹格处理软件，⽀持多种格式

A1：这是由于不同软件使⽤不同的坐标系统造成的。解决⽅法：

Blender：导出FBX时，将Forward设置为"-Y Forward"，Up设置为"Z Up"

Maya：导出FBX时，在Advanced Options中将Axis Conversion设置为正确的坐标系

通⽤解决⽅案：在UE导⼊时，可以在Import Options中调整Transform设置

A2：CAD模型通常精度很⾼，⾯数较多。建议：

1. 在CAD软件中简化模型，去除不必要的细节

2. 使⽤抽取⼯具降低⾯数

3. 考虑制作LOD（细节层次）模型

4. 将复杂模型分解为多个简单部件

https://docs.unrealengine.com/5.0/en-US/datasmith-supported-software-and-fil

e-types/

https://docs.unrealengine.com/4.27/en-US/Basics/Coordinates/

6.4 格式转换⼯具

https://www.autodesk.com/developer-network/platform-technologies/fbx-conve

rter-archives

7.常⻅问题

Q1：使⽤其他三维建模软件（如Blender、

Maya）时，导出的FBX模型在UE中显⽰⽅向不正确

怎么办？

Q2：使⽤CAD软件（如SOLIDWORKS）导出的模

型⽂件很⼤，导⼊UE后性能很差怎么办？
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A3：不同软件的材质系统差异导致。解决⽅法：

1. FBX导出时：确保勾选"Embed Media"选项，将贴图嵌⼊FBX⽂件

2. ⼿动重新指定材质：在UE中为模型重新创建和指定材质

3. 使⽤Datasmith：对于复杂材质，建议使⽤Datasmith插件导⼊

1.  

2. 推荐配置请⻅：  

Q3：模型导⼊UE后材质丢失或显⽰为⽩⾊，怎么

处理？

https://rflysim.com/ ↩
https://rflysim.com/doc/zh/HowToInstall.pdf ↩
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